安装mysql时start service失败(MySQL安装,could not start the service)

本文目录
- MySQL安装,could not start the service
- mysql 安装到最后一步时,start service 为失败状态的解决方法
- 安装mysql5.1过程中Start service停住了` 出现这样的字can not start the service mysql.error:0 为什么会
- 在安装mysql时,最后出现Could not start the service Mysql,是哪里出问题了急!
- 安装MySql时,卡在最后一步Attempting to start service 的解决
- 安装mysql时,配置到最后start service 出现:Could Not Connect To The Service Control Manager
- MySQL安装最后一步start server总是错号
MySQL安装,could not start the service
从网上看到的,你可以试试:
在安装mysql数据库时,如果重新安装,很容易遇见apply security setting error,即在配置mysql启动服务时,在启动apply security setting时会出错,原因是卸载mysql时并没有完全删除文件,所以有必要手动清除这些,要清除的文件主要:
一、mysql的安装目录,一般为C:\Program Files目录下。
二、mysql的数据存放目录,一般在C:\Documents and Settings\All Users\Application Data目录下(需要注意的时Application Data这个文件夹默认是隐藏的,要通过 工具-》文件夹选项-》查看-》显示所有文件与文件夹 来设置隐藏文件可见)。
三、删除注册表数据,通过regedit,删除以下几个文件:
引用
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet002/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Eventlog/Applications/MySQL
mysql 安装到最后一步时,start service 为失败状态的解决方法
我以前也遇到过类似的情况。
再次运行mysql
的安装程序,安装过程中,不要选择安装,选择修复卸载。(用的英文版,差不多这个意思。)之后再安装一次就可以了。
安装mysql5.1过程中Start service停住了` 出现这样的字can not start the service mysql.error:0 为什么会
当各位在安装、重装时出现could not start the service mysql error:0
原因: 卸载mysql时并没有完全删除相关文件和服务,需要手动清除。
安装到最后一步execute时不能启动服务的解决方法:
首先,在管理工具-》服务里面将MySQL的服务给停止(有的是没有安装成功,有这个服务,但是已经停止了的),win+R—》cmd,打开命令提示符窗口,
输入命令:sc delete mysql(查看服务,此时服务中已没有mysql),将已停的服务删除,卸载MySQL记得选择remove。最后将MySQL安装目录删除,还有数据库的目录也删除。
解决的方法:命令提示符下输入regedit,打开注册表
把注册表
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet002/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Eventlog/Applications/MySQL
将相关目录下的键值,如果有相关mysql键值(mysql、mysqladmin)则删掉
注册表中有关MySQL的东西可能删除的不彻底,ctrl+F查找mysql,之后用F3循环查找,将有关MySQL这个软件的全部有关项删除
注意(删除项时出错):
无法删除 LEGACY_MYSQL51(自己建数据库时置的用户名): 删除项时出错。解决办法:注册表项里右键增加administrators所有权限
之后打开360安全卫士或金山卫士清理一下注册表!
删除MYSQL数据表目录(C:/Documents and Settings/All Users/Application Data/MySQL/MySQL Server 5.1/Data/)(Application Data是隐藏的,要在查看里面将其设置为显示
win7下一般在C:\ProgramData\MySQL目录下,注意ProgramData这个文件夹默认是隐藏的),
最后重启计算机,重新安装mysql. 运行向导Server Instance Configuration wizard,进行相关设置即可。
在安装mysql时,最后出现Could not start the service Mysql,是哪里出问题了急!
如果你确定之前的mysql卸载干净了,有可能是服务已经提前开启了,cmd里输入sc delete mysql,之后第三个打叉叉的那个安装窗口点击back,再next重新excute就可以成功
安装MySql时,卡在最后一步Attempting to start service 的解决
由于我的MySQL不知道什么原因突然打不开了并报了个10061的错,查了下原因说是因为数据库被连接发生冲突,麻烦死了于是重装,在最后一步的 start service 停了,安装失败,又重装了N次,还是失败。原因是已经装过MySQL的电脑上存在以注册项目,网上有很多说法,和方法,我试了一个成功了。基本步骤一下:
1、卸载MySQL应用程序,要把MySQL的服务业卸载掉,命令窗口使用: sc delete MySQL
2、清理注册表(找出来删掉)
复制代码代码如下:
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet002/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Eventlog/Applications/MySQL
3、清理残余文件项,特指MySQL的数据文件
1)安装目录有残余项,手动删除
2)显示隐藏文件及文件夹(文件夹选项-》查看-》显示隐藏文件的文件、文件夹和驱动器),这是避免你找不到目录,然后就去安装目录找吧,windows 7 下MySQL的数据文件在一个隐藏的ProgramData文件夹里,或者用懒人的办法,在搜索栏输入“mysql”,列出全部有关mysql的文件和文件夹。
4、重装MySQL,按照正常流程,成功了。
安装mysql时,配置到最后start service 出现:Could Not Connect To The Service Control Manager
安装MySQL时无法启动服务(could not start the service MYSQL .Error:0)
在安装mysql时,到最后一步,执行时,在start service,出现如下错误:
Could not start the service
一般的发生原因是因为多次安装,或卸载后重装时,才会出现这个问题,所以要把所有相关的文件夹、服务、注册表等都要卸载干净了,再次安装就OK了。
有如下解决办法:
使用services.msc打开服务窗口,查看MySQL service是否已经存在。如已经存在并已启动,则先停止该服务,然后到注册表("HKEY_LOCAL_MACHINE/SYSTEM /CurrentControlSet/Services")中删除对应服务,并使用命令sc delete MySQL,然后继续进行安装,就能成功。
MySQL安装最后一步start server总是错号
MySQL 5.1 安装过程中报apply security setting错误的解决办法
1, 卸载MySQL
2, 删除目录 C:\Documents and Settings\All Users\Application Data\MySQL
3, 重新安装MySQL 就 OK 啦
------------------------------------------
Could not start the service MySQL 解决方法
安装mysql 5.1.33,在运行Server Instance Configuration wizard时的Execute configurattion步骤中的第三项Start Service进出错,错误提示为Could not start the service MySQL (出现这种情况一般是因为装过mysql,卸载不干净造成的。卸载后重启后再重装。注意看下服务,如果未能卸载,可以用mysqld-nt -remove卸载)。
具体方法如下:
查看服务中有没有mysql,如果有将该服务停掉;
在控制面板中运行添加删除程序,将mysql卸载;
卸载后打开注册表,查看HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services 下的键值,如果有相关mysql键值(mysql、mysqladmin)则删掉,即可;
重启,将mysql的安装残余目录删掉 (查看服务,此时服务中已没有mysql);
重新安装mysql.安装后先不要运行Server Instance Configuration wizard,重启后在开始菜单中运行该向导,即可。
PS:一种值得参考的方法
---------------------------------------------
msyql安装到最后一步start service错误解决方法
1,到控制面板里面先把mysql删除.
2.到c盘C:\Program Files目录下把mysql目录删除.
3.如果在其他盘还有设置目录也要删除.空目录也要删除
4.到regedit把注册表
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet002/Services/Eventlog/Applications/MySQL
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Eventlog/Applications/MySQL
有的话,全部删除!
(技巧:用F3循环查找“mysql”)
5.如果任务管理器里有关mysql内容也删除
6,把防火墙关了
7,重新装mysql(这里我没有重启计算机)
重装时候有必要的话,重启计算机,停用IIS,和删除temp里的临时文件.
实在不行的话,配置mysql时候,把mysql服务换个服务名.
******************************************************************************************
---------------------------
删除项时出错。
---------------------------
无法删除 LEGACY_MYSQL51: 删除项时出错。
---------------------------
确定
---------------------------
解决办法:注册表项里右键增加administrators所有权限来源:上海简爱网络 www.lixun.net
***隐藏网址***

更多文章:
session已过期重新授权(苹果手机session过期怎么恢复啊)
2026年3月8日 10:00
scrapy中间件(scrapy框架中setting中中间件数字大的先执行么)
2026年8月22日 13:45
matlab定义变量并赋初值(在matlab中用输入量给变量赋值)
2026年6月11日 15:00
程序设计语言是如何通过a b+1的(C语言中c=(a+b,a++,b+1);什么意思)
2026年6月29日 19:30
apache中国官网(中国sns交友网站排行前十名分别是什么)
2025年6月30日 20:45
eclipse创建的项目在哪里(Eclipse的src文件在哪里啊)
2026年8月31日 03:15
什么是函数?js正则查找match()与替换replace()用法实例
2025年9月29日 19:00
frameset标签的属性(在html标签中的frameset是什么标签 又有哪些属性和值)
2025年12月6日 02:15
translate最新消息(‘请以最新的信息为准’ 怎么翻译)
2026年6月5日 08:00
thymeleaf使用ajax(如何在Thymeleaf中实现ajax请求url的可靠构造)
2025年6月24日 09:00















