mysql server下载(MySQL Server 5.0那里有下载)

本文目录
MySQL Server 5.0那里有下载
***隐藏网址***
这里可以下载!
如果不行你就去天空或华军下载吧!下面是网址
***隐藏网址***
***隐藏网址***
linux中怎样安装mysql数据库服务器
第一种:直接使用 yum -y install mysql-server
第二种
使用rpm安装Mysql
1、下载MySQL的安装文件
安装MySQL需要下面两个文件:
MySQL-server-4.0.16-0.i386.rpm
MySQL-client-4.0.16-0.i386.rpm
***隐藏网址***
2、安装MySQL
rpm文件是Red Hat公司开发的软件安装包,rpm可让Linux在安装软件包时免除许多复杂的手续。该命令在安装时常用的参数是 –ivh ,其中i表示将安装指定的rmp软件包,V表示安装时的详细信息,h表示在安装期间出现“#”符号来显示目前的安装过程。这个符号将持续到安装完成后才停止。
1)安装服务器端
在有两个rmp文件的目录下运行如下命令:
# rpm -ivh MySQL-server-4.0.16-0.i386.rpm
显示如下信息。
warning: MySQL-server-4.0.16-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
Preparing... ###########################################
1:MySQL-server ###########################################
。。。。。。(省略显示)
/usr/bin/mysqladmin -u root password ’new-password’
/usr/bin/mysqladmin -u root -h test1 password ’new-password’
。。。。。。(省略显示)
Starting mysqld daemon with databases from /var/lib/mysql
如出现如上信息,服务端安装完毕。测试是否成功可运行netstat看Mysql端口是否打开,如打开表示服务已经启动,安装成功。Mysql默认的端口是3306。
# netstat -nat
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp00 0.0.0.0:3306 0.0.0.0:* LISTEN
上面显示可以看出MySQL服务已经启动。
2)安装客户端
运行如下命令:
# rpm -ivh MySQL-client-4.0.16-0.i386.rpm
warning: MySQL-client-4.0.16-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
Preparing...###########################################
1:MySQL-client ###########################################
显示安装完毕。
用下面的命令连接mysql,测试是否成功。
注:其实也可以下载压缩文件,到本地后直接解压缩即可。
二、登录MySQL
登录MySQL的命令是mysql, mysql 的使用语法如下:
mysql
username 与 password 分别是 MySQL 的用户名与密码,mysql的初始管理帐号是root,没有密码,注意:这个root用户不是Linux的系统用户。MySQL默认用户是root,由于初始没有密码,第一次进时只需键入mysql即可。
# mysql
Welcome to the MySQL monitor. Commands end with ; or /g.
Your MySQL connection id is 1 to server version: 4.0.16-standard
Type ’help;’ or ’/h’ for help. Type ’/c’ to clear the buffer.
mysql》
出现了“mysql》”提示符,恭喜你,安装成功!
增加了密码后的登录格式如下:
mysql -u root -p
Enter password: (输入密码)
其中-u后跟的是用户名,-p要求输入密码,回车后在输入密码处输入密码。
注意:
1.这个mysql文件在/usr/bin目录下,与后面讲的启动文件/etc/init.d/mysql不是一个文件。
2.如果从本地登录其他主机,则格式如下:
./mysql -u root -p -h 192.168.xx.xx
前面必须加./
三、MySQL的几个重要目录
MySQL安装完成后不象SQL Server默认安装在一个目录,它的数据库文件、配置文件和命令文件分别在不同的目录,了解这些目录非常重要,尤其对于Linux的初学者,因为 Linux本身的目录结构就比较复杂,如果搞不清楚MySQL的安装目录那就无从谈起深入学习。
下面就介绍一下这几个目录。
1、数据库目录
/var/lib/mysql/
2、配置文件
/usr/share/mysql(mysql.server命令及配置文件)
3、相关命令
/usr/bin(mysqladmin mysqldump等命令)
4、启动脚本
/etc/rc.d/init.d/(启动脚本文件mysql的目录)
四、修改登录密码
MySQL默认没有密码,安装完毕增加密码的重要性是不言而喻的。
1、命令
usr/bin/mysqladmin -u root password ’new-password’
格式:mysqladmin -u用户名 -p旧密码 password 新密码
2、例子
例1:给root加个密码123456。
键入以下命令 :
# /usr/bin/mysqladmin -u root password 123456
注:因为开始时root没有密码,所以-p旧密码一项就可以省略了。
3、测试是否修改成功
1)不用密码登录
# mysql
ERROR 1045: Access denied for user: ’root@localhost’ (Using password: NO)
显示错误,说明密码已经修改。
2)用修改后的密码登录
# mysql -u root -p
Enter password: (输入修改后的密码123456)
Welcome to the MySQL monitor. Commands end with ; or /g.
Your MySQL connection id is 4 to server version: 4.0.16-standard
Type ’help;’ or ’/h’ for help. Type ’/c’ to clear the buffer.
mysql》
成功!
这是通过mysqladmin命令修改口令,也可通过修改库来更改口令。
五、启动与停止
1、启动
MySQL安装完成后启动文件mysql在/etc/init.d目录下,在需要启动时运行下面命令即可。
# /etc/init.d/mysql start
2、停止
/usr/bin/mysqladmin -u root -p shutdown
3、自动启动
1)察看mysql是否在自动启动列表中
# /sbin/chkconfig –list
2)把MySQL添加到你系统的启动服务组里面去
# /sbin/chkconfig – add mysql
3)把MySQL从启动服务组里面删除。
# /sbin/chkconfig – del mysql
六、更改MySQL目录
MySQL默认的数据文件存储目录为/var/lib/mysql。假如要把目录移到/home/data下需要进行下面几步:
1、home目录下建立data目录
cd /home
mkdir data
2、把MySQL服务进程停掉:
mysqladmin -u root -p shutdown
3、把/var/lib/mysql整个目录移到/home/data
mv /var/lib/mysql /home/data/
这样就把MySQL的数据文件移动到了/home/data/mysql下
4、找到my.cnf配置文件
如果/etc/目录下没有my.cnf配置文件,请到/usr/share/mysql/下找到*.cnf文件,拷贝其中一个到/etc/并改名为my.cnf)中。命令如下:
# cp /usr/share/mysql/my-medium.cnf /etc/my.cnf
5、MySQL的配置文件/etc/my.cnf
为保证MySQL能够正常工作,需要指明mysql.sock文件的产生位置。 修改socket=/var/lib/mysql/mysql.sock一行中等号右边的值为:/home/mysql/mysql.sock 。操作如下:
vi my.cnf (用vi工具my.cnf文件,找到下列数据修改之)
# The MySQL server
port = 3306
#socket = /var/lib/mysql/mysql.sock(原内容,为了更稳妥用“#”注释此行)
socket = /home/data/mysql/mysql.sock (加上此行)
6、修改MySQL启动脚本/etc/rc.d/init.d/mysql
最后,需要修改MySQL启动脚本/etc/rc.d/init.d/mysql,把其中datadir=/var/lib/mysql一行中,等号右边的路径改成你现在的实际存放路径:home/data/mysql。
# vi /etc/rc.d/init.d/mysql
#datadir=/var/lib/mysql(注释此行)
datadir=/home/data/mysql (加上此行)
7、重新启动MySQL服务
/etc/rc.d/init.d/mysql start
或用reboot命令重启Linux
如果工作正常移动就成功了,否则对照前面的7步再检查一下。
七、MySQL的常用操作
注意:MySQL中每个命令后都要以分号;结尾。
1、显示数据库
mysql》 show databases;
+----------+
| Database |
+----------+
| mysql|
| test |
+----------+
2 rows in set (0.04 sec)
Mysql刚安装完有两个数据库:mysql和test。mysql库非常重要,它里面有MySQL的系统信息,我们改密码和新增用户,实际上就是用这个库中的相关表进行操作。
2、显示数据库中的表
mysql》 use mysql; (打开库,对每个库进行操作就要打开此库)
Database changed
mysql》 show tables;
+-----------------+
| Tables_in_mysql |
+-----------------+
| columns_priv|
| db |
| func|
| host|
| tables_priv |
| user|
+-----------------+
6 rows in set (0.01 sec)
3、显示数据表的结构:
describe 表名;
4、显示表中的记录:
select * from 表名;
例如:显示mysql库中user表中的纪录。所有能对MySQL用户操作的用户都在此表中。
Select * from user;
5、建库:
create database 库名;
例如:创建一个名字位aaa的库
mysql》 create databases aaa;
6、建表:
use 库名;
create table 表名 (字段设定列表);
例如:在刚创建的aaa库中建立表name,表中有id(序号,自动增长),xm(姓名),xb(性别),csny(出身年月)四个字段
use aaa;
mysql》 create table name (id int(3) auto_increment not null primary key, xm char(8),xb char(2),csny date);
可以用describe命令察看刚建立的表结构。
mysql》 describe name;
+-------+---------+------+-----+---------+----------------+
| Field | Type| Null | Key | Default | Extra |
+-------+---------+------+-----+---------+----------------+
| id| int(3) | | PRI | NULL| auto_increment |
| xm| char(8) | YES | | NULL||
| xb| char(2) | YES | | NULL||
| csny | date| YES | | NULL||
+-------+---------+------+-----+---------+----------------+
7、增加记录
例如:增加几条相关纪录。
mysql》 insert into name values(’’,’张三’,’男’,’1971-10-01’);
mysql》 insert into name values(’’,’白云’,’女’,’1972-05-20’);
可用select命令来验证结果。
mysql》 select * from name;
+----+------+------+------------+
| id | xm | xb | csny |
+----+------+------+------------+
| 1 | 张三 | 男 | 1971-10-01 |
| 2 | 白云 | 女 | 1972-05-20 |
+----+------+------+------------+
8、修改纪录
例如:将张三的出生年月改为1971-01-10
mysql》 update name set csny=’1971-01-10’ where xm=’张三’;
9、删除纪录
例如:删除张三的纪录。
mysql》 delete from name where xm=’张三’;
10、删库和删表
drop database 库名;
drop table 表名;
11.查看mysql版本
在mysql5.0中命令如下:
show variables like ’version’;
或者:select version();
八、增加MySQL用户
格式:grant select on 数据库.* to 用户名@登录主机 identified by "密码"
例1、增加一个用户user_1密码为123,让他可以在任何主机上登录,并对所有数据库有查询、插入、修改、删除的权限。首先用以root用户连入MySQL,然后键入以下命令:
mysql》 grant select,insert,update,delete on *.* to user_1@"%" Identified by "123";
例1、增加的用户是十分危险的,如果知道了user_1的密码,那么他就可以在网上的任何一台电脑上登录你的MySQL数据库并对你的数据为所欲为了,解决办法见例2。
例2、增加一个用户user_2密码为123,让此用户只可以在localhost上登录,并可以对数据库aaa进行查询、插入、修改、删除的操作(localhost指本地主机,即MySQL数据库所在的那台主机),这样用户即使用知道user_2的密码,他也无法从网上直接访问数据库,只能通过 MYSQL主机来操作aaa库。
mysql》grant select,insert,update,delete on aaa.* to user_2@localhost identified by "123";
用新增的用户如果登录不了MySQL,在登录时用如下命令:
mysql -u user_1 -p -h 192.168.113.50 (-h后跟的是要登录主机的ip地址)
九、备份与恢复
1、备份
例如:将上例创建的aaa库备份到文件back_aaa中
# cd /home/data/mysql (进入到库目录,本例库已由val/lib/mysql转到/home/data/mysql,见上述第六部分内容)
# mysqldump -u root -p --opt aaa 》 back_aaa
2、恢复
# mysql -u root -p ccc 《 back_aaa
下载mysql需要把sql server删除吗
下载mysql需要把sql server删除,方式如下
1 .控制面板中卸载mysql软件
2.删除安装程序比如 d:D:\MySQL\MySQL Server 5.5
3.最关键的一步。C:\Documents and Settings\All Users\Application Data\mysql给删除掉,这里需要注意的是Application
Data是隐藏的,所以首先要把隐藏的文件夹给显示出来,然后在执行删除。这样就ok了。
求一个MySQL安装包+安装教程
方法/步骤MySQL安装文件分为两种,一种是msi格式的,一种是zip格式的。如果是msi格式的可以直接点击安装,按照它给出的安装提示进行安装(相信大家的英文可以看懂英文提示),一般MySQL将会安装在C:\ProgramFiles\MySQL\MySQLServer5.6该目录中;zip格式是自己解压,解压缩之后其实MySQL就可以使用了,但是要进行配置。解压之后可以将该文件夹改名,放到合适的位置,个人建议把文件夹改名为MySQLServer5.6,放到C:\ProgramFiles\MySQL路径中。当然你也可以放到自己想放的任意位置。完成上述步骤之后,很多用户开始使用MySQL,但会出现图示的错误。这是因为没有配置环境变量所致。配置环境变量很简单:我的电脑-》属性-》高级-》环境变量选择PATH,在其后面添加:你的mysqlbin文件夹的路径(如:C:\ProgramFiles\MySQL\MySQLServer5.6\bin)PATH=.;C:\ProgramFiles\MySQL\MySQLServer5.6\bin(注意是追加,不是覆盖)配置完环境变量之后先别忙着启动mysql,我们还需要修改一下配置文件(如果没有配置,之后启动的时候就会出现图中的错误哦!:错误2系统找不到文件),mysql-5.6.1X默认的配置文件是在C:\ProgramFiles\MySQL\MySQLServer5.6\my-default.ini,或者自己建立一个my.ini文件,在其中修改或添加配置(如图):basedir=C:\ProgramFiles\MySQL\MySQLServer5.6(mysql所在目录)datadir=C:\ProgramFiles\MySQL\MySQLServer5.6\data(mysql所在目录\data)以管理员身份运行cmd(一定要用管理员身份运行,不然权限不够),输入:cdC:\ProgramFiles\MySQL\MySQLServer5.6\bin进入mysql的bin文件夹(不管有没有配置过环境变量,也要进入bin文件夹,否则之后启动服务仍然会报错误2)输入mysqld-install(如果不用管理员身份运行,将会因为权限不够而出现错误:Install/RemoveoftheServiceDenied!)安装成功安装成功后就要启动服务了,继续在cmd中输入:netstartmysql(如图),服务启动成功!此时很多人会出现错误,请看注意:注意:这个时候经常会出现错误2和错误1067。如果出现“错误2系统找不到文件”,检查一下是否修改过配置文件或者是否进入在bin目录下操作,如果配置文件修改正确并且进入了bin文件夹,需要先删除mysql(输入mysqld-remove)再重新安装(输入mysqld-install);如果出现错误1067,那就是配置文件修改错误,确认一下配置文件是否正确。服务启动成功之后,就可以登录了,如图,输入mysql-uroot-p(第一次登录没有密码,直接按回车过),登录成功!
我初学MySQL,下载哪个版本..
你应该到MySQL Community Server就可以了
MSI是安装版,ZIP是免安装版,免安装就是把别人已经安装好的东西打包给你
建议安装MSI,因为它比较小,网速快的话,很快搞定,免安装体积大了点,浪费时间呀
直接下载x86 32位就可以
你想通过jdbc连接mysql就得去MySQL Connectors下载jar包,进入MySQL Connectors
点击Connector/J
给你图吧

更多文章:
cadence adc仿真(Cadence教程3——与非电路原理图仿真以及版图绘制)
2025年12月27日 10:15
电脑中recent是什么(请问我的电脑里C盘上recent里有很多快捷方式图标,它们有什么用,能删除吗)
2026年4月12日 09:15
安卓permission denied(adb 遇到 Permission denied)
2025年12月28日 14:30
excel函数公式大全讲解乘法(excel乘法公式,财务人士必看)
2025年6月28日 18:45
java开发工具包怎么查看(java.util.* 这一类的包在哪里能查看其内容和作用)
2026年3月19日 05:00
简易php聊天室(用php做的聊天室CPU占用很高怎么解决)
2025年11月20日 08:45
delphi源码特殊标记(在delphi里怎么快速将一段代码加成注释)
2026年8月27日 21:45
西门子plc编程软件是什么(西门子PLC编程软件是西门子通用软件吗)
2025年6月5日 19:00















