rsync默认端口号(ubuntu16.04怎么安装ssh)

本文目录
ubuntu16.04怎么安装ssh
你好,
安装SSH服务端和客户端代码如下复制代码sudo apt-get install openssh-server openssh-client
将 文件/文件夹 从远程Ubuntu机拷至本地(scp)代码如下复制代码scp -r username@192.168.0.1:/home/username/remotefile.txt .
将 文件/文件夹 从本地拷至远程 Ubuntu 机(scp)代码如下复制代码scp -r localfile.txt username@192.168.0.1:/home/username/
将 文件/文件夹 从远程 Ubuntu 机拷至本地(rsync)代码如下复制代码rsync -v -u -a --delete --rsh=ssh --stats username@192.168.0.1:/home/username/remotefile.txt .
将 文件/文件夹 从本地拷至远程 Ubuntu 机(rsync)代码如下复制代码rsync -v -u -a --delete --rsh=ssh --stats localfile.txt username@192.168.0.1:/home/username/
其它的一些参数
要让本机开放SSH服务就需要安装openssh-server:代码如下复制代码sudo apt-get install openssh-server
查看sshserver是否运行:代码如下复制代码ps-e |grep ssh
运行sshserver:代码如下复制代码sudo /etc/init.d/ssh start
ssh-server配置文件位于/etc/ssh/sshd_config,可以自定义SSH的服务端口。
默认端口是22,自定义端口后需重启SSH服务:代码如下复制代码sudo /etc/init.d/ssh stop
sudo /etc/init.d/ssh start登陆SSH:代码如下复制代码ssh username@localhost
如何rsync同步非标准SSH接口
一、rsync简介
一于蘳ync简介
server会开一个873端口,等待客户端去连接,连接时,rsync
server会检查口令是否相符,若通过口令查核,则可以通过进行文件传输,第一次连通完成时,会把整份文件传输一次,以后则就只需进行增量备份;
-v,--verbose 详细模式输出;
-a,--archive 归档模式,表示以递归的方式传输文件,并保持所有文件属性不变,相当于使用了组合参数-rlptgoD;
-r, --recursive 对子目录以递归模式处理;
-l, --links 保留软链结;
-p, --perms 保持文件权限;
-t, --times 保持文件时间信息;
-g, --group 保持文件属组信息;
-o, --owner 保持文件属主信息;
-D, --devices 保持设备文件信息;
-H, --hard-links 保留硬链结;
-S, --sparse 对稀疏文件进行特殊处理以节省DST的 空间;
--delete 删除那些DST中SRC没有的文件;
-z, --compress 对备份的文件在传输时进行压缩处理;
三、rsync的六种不同的工作模式;
三、rsync的六种不
当SRC和DES路径信息中不包含冒号“:”分隔符时,就启用这种工作模式:
# rsync -avSH /home/coremail/ /cmbak/
2)使用一个远程shell程序(如rsh、ssh)来实现将本地机器的内容拷贝到远程机器,当DST路径地址包括冒号“:”分隔符时启动该模式;
# rsync -avSH /home/coremail/ 192.168.11.12:/home/coremail/
3)使用一个远程shell程序(如rsh、ssh)来实现将远程机器的内容拷贝到本地机器,当SRC地址路径包括冒号“:”分隔符时启动该模式;
# rsync -avSH 192.168.11.11:/home/coremail/ /home/coremail/
4)从远程rsync服务器中拷贝文件到本地机。当SRC路径信息包含“::”分隔符时启动该模式。
如:rsync -av root@172.16.78.192::www /databack
5)从本地机器拷贝文件到远程rsync服务器中。当DST路径信息包含“::”分隔符时启动该模式。
如:rsync -av /databack root@172.16.78.192::www
6)列远程机的文件列表。这类似于rsync传输,不过只要在命令中省略掉本地机信息即可。
如:rsync -v rsync://192.168.11.11/data
四、rsync服务端的配置;
环境:192.168.11.11为生产机;192.168.11.12为备份机;
那么需要192.168.11.11需要作为rsync的client;
192.168.11.12作为rsync的service端;
1、192.168.11.12_service端的配置;
1)# touch /etc/rsyncd.conf //此文件为rsync的主配置问题,默认不存在需要手动创建;
2)定义同步的配置;
# cat /etc/rsyncd.conf
path = /data/
auth users = coremail
uid = root
gid = root
sid = root
read only = no
Path = /home/coremail/var/mysql
Path = /ho e/coremail
uid = root
gid = root
secrets file = /etc/rsyncd.secrets
read only = no
Path = /home/coremail/
auth users = coremail
uid = root
gid = root
secrets file = /etc/rsyncd.secrets
read only = no
3)定义密码文件/etc/rsyncd.secrets
# cat /etc/rsyncd.secrets
[rremail:coremail
4)启动rsync启动服务
# cat /etc/xinetd.d/rsync
# default: off
# description: The rsync server is a good addition to an ftp server, as it \
# allows crc checksumming etc.
service rsync
{
disable = yes //需要修改为no;
socket_type = stream
wait = no
user = root
server = /usr/bin/rsync
server_args = --daemon
log_on_failure += USERID
}
# chkconfig --level 2345 rsync on
# chkconfig rsync on
# chkconfig --level 2345 xinetd on
# service xinetd restart
Stopping xinetd:
Starting xinetd:
2、192.168.11.11_client端的配置;
# cat /etc/rsyncd.secrets
coremail
# rsync -aSvH --password-file=/etc/rsyncd.secrets /home/coremail/coremail@192.168.11.12::mysql
# rsync -aSvH --password-file=/etc/rsyncd.secrets /home/coremail/coremail@192.168.11.12::cmxt
五、定义定时自行rsync同步,指定同步的日志所在的路径/var/log/rsync/下;
# cat /root/rsync.sh
DATE=`date +%Y%m%d%H%M`
rsync -aSvH --password-file=/etc/rsyncd.secrets /home/coremail/ coremail@192.168.11.12::data》/var/log/rsync.date.$DATE
rsync -aSvH --password-file=/etc/rsyncd.secrets /home/coremail/ coremail@192.168.11.12::mysql》/var/log/rsync.mysql.$DATE
rsync -aSvH --password-file=/etc/rsyncd.secrets /home/coremail/ coremail@192.168.11.12::cmxt》/var/log/rsync.cmxt.$DATE
chmod u+x /root/rsync.sh
# crontab -l
0 3 * * * /root/rsync.sh
执行时候的日子记录文件:
# ls |grep ’rsync’
rsync.cmxt.201110180915
rsync.date.201110180915
rsync.mysql.201110180915
receiving incremental file list时间很长 怎么解决
问题 @ERROR: chroot failed
@ERROR: chroot failed rsync error: error starting client-server protocol (code 5) at main.c(1503)
原因:
服务器端的目录不存在或无权限。
解决办法:
创建目录并修正权限可解决问题。
问题 skipping non-regular file
receiving incremental file list
skipping non-regular file “vendor/bin/doctrine”
skipping non-regular file “vendor/bin/doctrine.php”
sent 1990 bytes received 489209 bytes 327466.00 bytes/sec total size is 182515746 speedup is 371.57
原因:
source源文件有软链接。
解决方法:
修改为 rsync -va,其中 -a == -rlptgoD (no -H,-A,-X) 或者 rsync -rvltOD 也可以。
解决后:
receiving incremental file list
vendor/bin/doctrine -》 ../doctrine/orm/bin/doctrine
vendor/bin/doctrine.php -》 ../doctrine/orm/bin/doctrine.php
sent 1998 bytes received 489279 bytes 327518.00 bytes/sec total size is 182515746 speedup is 371.51
问题@ERROR: module is read only
sending incremental file list
ERROR: module is read only
rsync error: syntax or usage error (code 1) at main.c(866)
rsync: read error: Connection reset by peer (104)
rsync error: error in rsync protocol data stream (code 12) at io.c(759)
原因:
source源服务器端权限设置read为only只读权限。
解决方法:
read only = false
问题@ERROR: auth failed on module tee
@ERROR: auth failed on module tee rsync error: error starting client-server protocol (code 5) at main.c(1522)
原因:
服务器端该模块(tee)需要验证用户名密码,但客户端没有提供正确的用户名密码,认证失败。
解决方法:
提供正确的用户名密码解决此问题。
问题 @ERROR: Unknown module ‘tee_nonexists’
@ERROR: Unknown module ‘tee_nonexists’ rsync error: error starting client-server protocol (code 5) at main.c(1522)
原因:
服务器不存在指定模块。
解决方法:
提供正确的模块名或在服务器端修改成你要的模块以解决问题。
问题 password file must not be other-accessible
password file must not be other-accessible
continuing without password file
Password:
原因:
这是因为rsyncd.pwd rsyncd.secrets的权限不对,应该设置为600。
解决方法:
chmod 600 rsyncd.pwd
问题 rsync: failed to connect No route to host
rsync: failed to connect to 192.168.1.10: No route to host (113) rsync error: error in socket IO (code 10) at clientserver.c(104)
原因:
对方没开机、防火墙阻挡、通过的网络上有防火墙阻挡,都有可能。
解决方法:
在iptables 中开放该端口,语句如下:
iptables -I INPUT -p tcp –dport 873 -j ACCEPT
rsync默认端口873,其实就是把tcp udp的873端口打开。
问题 rsync error: error starting client-server protocol
rsync error: error starting client-server protocol (code 5) at main.c(1524)
原因:
/etc/rsyncd.conf配置文件内容有错误。请正确核对配置文件。
问题 rsync: chown “” failed: Invalid argument (22)
rsync: chown “” failed: Invalid argument (22)
原因:
权限无法复制。去掉同步权限的参数即可。(这种情况多见于Linux向Windows的时候)

更多文章:
tomcat的默认端口(tomcat打开8443端口是怎么回事)
2026年4月19日 12:15
constantly中文翻译(翻译:When you constantly live your life in Have)
2026年8月13日 13:30
javajsch下载图片(JAVA_JSCH如何远程操作SFTP服务器上的文件)
2026年9月23日 03:00
oracle vm virtualbox使用(oracle virtualbox 虚拟机网络)
2026年8月12日 12:00
coriander(coriander是什么东西啊怎么翻译)
2026年2月19日 00:00
idea无法创建springboot项目(如何用idea创建 spring boot工程)
2025年8月8日 17:30
whatsoever(whatsoever 这个词是什么意思啊 大家帮忙!)
2025年7月15日 03:45
数据库误删后能恢复吗(如果数据库的数据被你不小心删了 怎样恢复啊)
2025年6月25日 03:45
王业不偏安的下一句王业不偏安的下一句是什么?王业不偏安是什么意思 王业不偏安的原文及翻译
2026年9月13日 16:45
算法导论第三版pdf(《算法导论》第二版和第三版的区别大吗有中文版的吗)
2025年8月1日 01:30
















