linux怎么安装ssh(Linux下快速安装部署远程连接软件SSH的简明教程)

本文目录
Linux下快速安装部署远程连接软件SSH的简明教程
SSH分为客户端和服务端。
服务端是一个守护进程,一般是sshd进程,在后台运行并响应来自客户端的请求。提供了对远程请求的处理,一般包括公共密钥认证、密钥交换、对称密钥加密和非安全连接。
客户端一般是ssh进程,另外还包含scp、slogin、sftp等其他进程。
工作机制:
1. 客户端发送一个连接请求到远程服务端
2. 服务端检查申请的包和IP地址,再发生密钥给SSH客户端;
3. 客户端再将密钥发回服务端,自此建立连接。
下面我们开始正文:
一、客户端
1. 安装客户端(客户端不是必须的)
代码如下:
# apt-get install ssh
如果安装失败,则使用下面命令进行安装
代码如下:
# apt-get install openssh-client
2. SSH登录(客户端)
代码如下:
$ ssh 192.168.159.128
$ ssh -l weiyg 192.168.159.128
$ ssh weiyg@192.168.159.128
二、服务端
1. 安装服务器
代码如下:
# apt-get install openssh-server
2. 启动服务器
代码如下:
# /etc/init.d/ssh stop #停止
# /etc/init.d/ssh start #启动
# /etc/init.d/ssh restart #重启
3. SSH配置
修改配置文件/etc/ssh/sshd_config,并重启服务
代码如下:
# /etc/init.d/ssh restart
ssh默认端口是22,需要的话,自行修改
代码如下:
Port 20
ssh默认配置是允许root登录的,可以修改配置表禁止其登录
代码如下:
PermitRootLogin no
Linux配置ssh
1、购买服务器
2、加入安全组
3、修改实例名称,修改实例密码
1 查看ssh配置
2 安装SSH
3 启动服务
4 查看ssh服务的状态
输入以下命令:
5 在电脑终端输入
1.添加文件
2.添加公钥到文件内(id_rsa.pub)
3.ssh配置文件:
4.重启sshd服务
5 在电脑终端输入
常见错误:
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:sbd8mG3CPJc81mLgPPwLwVy7LF8qvUUuXisbcPKzTyE.
Please contact your system administrator.
Add correct host key in /Users/admin/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /Users/admin/.ssh/known_hosts:12
ECDSA host key for 47.96.118.128 has changed and you have requested strict checking.
Host key verification failed.
解决办法如下 输入
然后重新连接即可。
linux 配置ssh有几种方法
直接使用Linux系 统的root帐户登录系统,在很多环境下是不允许。而且如果网络中的所有机器都能使用ssh登录关键服务器也是不允许的。这就要求我们需要使用一些手段, 现在root帐号的登录,而且是只有指定的几台机器才能登录。当然限制登录的ip这些通过网络设备也恩那个完成。但是我们只需要了解怎么使用系统自己的功 能实现,这是每一个系统管理员都比较了解的。
1,修改ssh的配置文件,是root用户只能通过本地登录,不能通过远程ssh连接服务器。
vim /etc/ssh/sshd_config,
把#PermitRootLogin yes改成
PermitRootLogin no,然后重启ssh服务器,root用户就不能通过ssh远程登录系统了,只能通过一个普通帐号su或者本地登录。
2,可以同修改其他系统配置文件,使之能通过几个指定的IP远程ssh登录服务器。把下面这段放到root的.bash_profile文件中
ALLOWHOSTSLIST="192.168.163.1"
REMOTEHOST=$(env | grep SSH_CLIENT | awk ’{print $1}’ | awk -F "=" ’{print $2}’)
if echo "${ALLOWHOSTSLIST}" | grep "${REMOTEHOST}" 》 /dev/null
then :
else
exit
fi
结果就只能通过IP地址是192.168.163.1这台服务器通过ssh远程连接本服务器了。
3,可以把需要ssh远程服务器的IP地址添加到/etc/hosts.allow,例如下面的操作:
sshd:192.168.163.1:allow #只允许这个IP地址ssh登录
sshd:192.168.163.:allow #允许这个网段的所有IP地址ssh登录
sshd:all:deny #拒绝所有没有出现在上面的IP地址的ssh连接
4,也可以使用iptables指定能够远程ssh到服务器的IP地址
iptables -A INPUT -p tcp --dport 22 -s 192.168.163.1 -j ACCEPT #允许这个IP地址ssh连接本服务器
iptables -A INPUT -p tcp --dport 22 -s 192.168.163.0/24 -j ACCEPT #允许这个网段的所有IP远程ssh连接本服务器
iptables -A INPUT -p tcp --dport 22 -j DROP #除了上面允许的IP地址外,都拒绝使用ssh连接到服务器
linux ssh 升级安装方法
一、安装 Zlib
1、下载最新版本 Zlib
***隐藏网址***
# cd /usr/local/src
***隐藏网址***
2、编译安装 Zlib
# tar xzvf zlib-1.2.3.tar.gz
# cd zlib-1.2.3
# ./configure --prefix=/usr/local/zlib
# make
# make install
这样,就把 zlib 编译安装在
/usr/local/zilib 中了。
二、安装 OpenSSL
1、下载最新版本 OpenSSL
***隐藏网址***
# cd /usr/local/src
***隐藏网址***
2、编译安装 OpenSSL
# tar xzvf openssl-0.9.8d.tar.gz
# cd openssl-0.9.8d
# ./Configure --prefix=/usr/local/openssl
# make
# make test(这一步很重要哦!是进行 SSL加密协议的完整测试,如果出现错误就要一定先找出哪里的原因,否则一味继续可能导致最终 SSH 不能使用,后果很严重哦!)
# make install
三、安装 OpenSSH
1、下载最新版本 OpenSSH
***隐藏网址***
# cd /usr/local/src
# wget -c ftp://ftp.it.net.au/mirrors/OpenBSD/OpenSSH/portable/openssh-4.5p1.tar.gz
2、编译安装 OpenSSH
# tar xzvf openssh-4.5p1.tar.gz
# cd openssh-4.5p1
# ./configure --prefix=/usr --sysconfdir=/etc/ssh --with-pam --with-zlib=/usr/local/zlib --with-ssl-dir=/usr/local/openssl --with-md5-passwords
(注意,如果 configure 时提示 PAM 有错误,那一般是因为系统中没有安装 pam-devel RPM 包,找到安装光盘,安装 pam-devel 就可以解决啦)
# make
# make install
这样就完成了整个安装 SSH 的工作,在安装完成后,我们还需要修改一下 OpenSSH 的配置文件进一步提升安全性。通过以上步骤完成的安装工作,OpenSSH 的配置文件在 /etc/ssh 下,其中 SSH Server 的配置文件是 sshd_config。
# vi /etc/ssh/sshd_config
找到:
CODE:
#Protocol 2,1修改为:
Protocol 2这样就禁用了 ssh v1 协议,只使用更安全的 ssh v2 协议。
X11Forwarding yes修改为:
X11Forwarding no禁用 X11 转发。
修改后保存退出。
● 生成ssh服务管理脚本
进入ssh解压目录
#cd /contrib/redhat
#cp sshd.init /etc/init.d/sshd
#chmod +x /etc/init.d/sshd
#chkconfig --add sshd
最后,启动 SSH 服务使修改生效:
# /etc/init.d/sshd restart
重启后确认一下当前的 OpenSSH 和 OpenSSL是否正确:
# ssh -v
如果看到了新的版本号就没问题啦!
独自等待补充:
在实践过程中,发现了如下问题:
1、提示Starting sshd:WARNING: initlog is deprecated and will be removed in a future release
根据国外的网站上面得到的信息是更改 initlog -c "$SNMPD $OPTIONS" success || failure
为"$SNMPD $OPTIONS" success || failure 也就是去掉前面的initlog -c 结果还是解决不了问题。
再查资料发现编译安装的ssh在启动服务的时候 需要更改文件路径而且一定注意修改路径,不然报错。
# . /etc/sysconfig/sshd
KEYGEN=/usr/local/bin/ssh-keygen
SSHD=/usr/local/sbin/sshd
RSA1_KEY=/usr/local/etc/ssh_host_key
RSA_KEY=/usr/local/etc/ssh_host_rsa_key
DSA_KEY=/usr/local/etc/ssh_host_dsa_key
请大家根据自己的实际情况更改!!

更多文章:
京东read1不充电?c语言中read1:是什么意思啊,它怎么用啊
2026年7月12日 17:00
幻灯片间的动画效果通过动画选项卡什么来设置(不同幻灯片之间的动画效果通过幻灯片放映菜单的什么命令来设置)
2026年9月14日 09:15
eclipse如何查看tomcat版本(eclipse中tomcat)
2025年10月17日 20:45
linux虚拟机与主机共享文件(虚拟机red hat linux共享文件夹不能共享)
2026年1月4日 03:45
carry on的用法及短语(carry out 和carry on 是一样的么在句子里可以相互变通么)
2026年7月5日 14:15
朴石医学检验实验室6人被采取刑事强制措施,会判多久?北京朴石实验室7人被批捕,该实验室违反了哪些法律法规
2025年11月14日 02:45


















