cluster is not connected(操作系统RHEL6,使用yum安装lvm2-cluster-2.02.87-6.el6.x86_64.rpm时安装失败 求高手!)

本文目录
- 操作系统RHEL6,使用yum安装lvm2-cluster-2.02.87-6.el6.x86_64.rpm时安装失败 求高手!
- mysql error1241:Operand should contain 1 column(s)
- centos6.5安装mysql cluster问题求助
- windows 2008 server cluster client access point is not noline 怎么处理
操作系统RHEL6,使用yum安装lvm2-cluster-2.02.87-6.el6.x86_64.rpm时安装失败 求高手!
估计是yum源你没有导入密钥。提示说NOKEY。
密钥一般都在/etc/pki/rpm-gpg这个文件夹下,楼主试试这个命令
在root用户,或者sudo命令下
# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-*
把rpm-gpg目录下的密钥全部导入进去,可能会有错误提示,无视了。
然后在安装应该就可以了
mysql error1241:Operand should contain 1 column(s)
mysql error1241:Operand shou--根据报错来看 ,你下面的一个查询返回了两个值 cou_name as 最优秀课程,sco_score as 成绩
--Operand should contain 1 column(s)
(select cou_name as 最优秀课程,sco_score as 成绩 from cou,sco where cou.cou_id=sco.cou_id group by stu_id having sco_score=max(sco_score)),
(select cou_name as 最差课程,sco_score as 成绩 from cou,sco where cou.cou_id=sco.cou_id group by stu_id having sco_score=min(sco_score)),ld contain 1 column(s)
centos6.5安装mysql cluster问题求助
mysql ndbcluster 安装
1.数据库规划:
操作系统 centos 6.3
ndbcluster 版本:MySQL-Cluster-gpl-7.4.8-1.el6.x86_64
2个管理节点、2个sql节点、2个数据节点(管理节点和sql节点放在同一台服务器上)
如下:
管理节点1 192.168.1.17
管理节点2 192.168.1.18
sql节点1 192.168.1.17
sql节点2 192.168.1.18
ndbd 节点1 192.168.1.19
ndbd 节点2 192.168.1.20
2.操作系统设置:
设置服务主机名称
关闭selinux和防火墙
设置内核参数和最大进程数
下载mysql集群
MySQL-Cluster-gpl-7.4.8-1.el6.x86_64.rpm-bundle.tar
上传到服务器的相应目录下如 /home/mysqlinstall
3.安装管理节点和sql节点:
To check if your system has any RPM version of any MySQL package currently installed, run:
shell》 rpm -qa | grep -i mysql
检查
# rpm -qa | grep -i mysql
mysql-libs-5.1.61-4.el6.x86_64
如果有删除
shell》 rpm -e mysql-libs-5.1.61-4.el6.x86_64
删除报错:
# rpm -e mysql-libs-5.1.61-4.el6.x86_64
error: Failed dependencies:
libmysqlclient.so.16()(64bit) is needed by (installed) postfix-2:2.6.6-2.2.el6_1.x86_64
libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) postfix-2:2.6.6-2.2.el6_1.x86_64
mysql-libs is needed by (installed) postfix-2:2.6.6-2.2.el6_1.x86_64
#
解决:
# rpm -e --nodeps mysql-libs-5.1.61-4.el6.x86_64
#
# rpm -ivh MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64.rpm
# rpm -ivh MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64.rpm
4.安装数据节点:
执行上面步骤
# rpm -ivh MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64.rpm
# rpm -ivh MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64.rpm
5.配置集群
管理节点建立目录
mkdir /var/lib/mysql-cluster
mkdir -p /data/mysql/ndbdata
5.启动关闭集群:
启动管理节点
ndb_mgmd -f /var/lib/mysql-cluster/config.ini --initial (第一次启动加--initial修改了配置文件后的启动)
启动数据节点
ndbmtd --initial
启动sql节点
service mysql start
查看集群状态
shell》 ndb_mgm -e "SHOW"
关闭管理节点和数据节点
ndb_mgm -e shutdown
关闭sql节点
service mysql stop
安装遇到的问题:
1.权限问题启动mysql报错
# service mysql start
Starting MySQL..The server quit without updating PID file (sql/sqlmgm2.pid).
#
# ll
total 110644
-rw-rw---- 1 mysql mysql 56 Dec 14 17:13 auto.cnf
-rw-rw---- 1 mysql mysql 12582912 Dec 14 17:39 ibdata1
-rw-rw---- 1 mysql mysql 50331648 Dec 14 17:40 ib_logfile0
-rw-rw---- 1 mysql mysql 50331648 Dec 14 17:13 ib_logfile1
drwx------ 2 mysql mysql 4096 Dec 14 17:39 mysql
drwx------ 2 root root 4096 Dec 14 17:39 ndbinfo
drwx------ 2 root root 4096 Dec 14 17:39 performance_schema
-rw-r----- 1 mysql mysql 30068 Dec 14 17:40 sqlmgm2.err
drwx------ 2 root root 4096 Dec 14 17:33 test
# chown mysql:mysql -R mysql
# service mysql start
Starting MySQL..
#
2.安装rpm包时,报包依赖关系如下:
# rpm -ivh MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64.rpm
warning: MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
error: Failed dependencies:
libnuma.so.1()(64bit) is needed by MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64
libnuma.so.1(libnuma_1.1)(64bit) is needed by MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64
libnuma.so.1(libnuma_1.2)(64bit) is needed by MySQL-Cluster-server-gpl-7.4.8-1.el6.x86_64
解决方法是把安装的依赖的包
# yum install numactl
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: mirrors.163.com
* extras: mirrors.opencas.cn
* updates: mirrors.opencas.cn
Setting up Install Process
Resolving Dependencies
--》 Running transaction check
---》 Package numactl.x86_64 0:2.0.9-2.el6 will be installed
--》 Finished Dependency Resolution
Dependencies Resolved
==============================================================================================================================
Package Arch Version Repository Size
==============================================================================================================================
Installing:
numactl x86_64 2.0.9-2.el6 base 74 k
Transaction Summary
==============================================================================================================================
Install 1 Package(s)
Total download size: 74 k
Installed size: 171 k
Is this ok : y
Downloading Packages:
numactl-2.0.9-2.el6.x86_64.rpm | 74 kB 00:00
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Importing GPG key 0xC105B9DE:
Userid : CentOS-6 Key (CentOS 6 Official Signing Key) 《centos-6-key@centos.org》
Package: centos-release-6-3.el6.centos.9.x86_64 (@anaconda-CentOS-201207061011.x86_64/6.3)
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Is this ok : y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : numactl-2.0.9-2.el6.x86_64 1/1
Verifying : numactl-2.0.9-2.el6.x86_64 1/1
Installed:
numactl.x86_64 0:2.0.9-2.el6
Complete!
3.启动数据库节点无法和管理节点相连
原因由于防火墙和selinux没有关闭
解决关闭防火墙和selinux
一、关闭防火墙
1、重启后永久性生效:
开启:chkconfig iptables on
关闭:chkconfig iptables off
2、即时生效,重启后失效:
开启:service iptables start
关闭:service iptables stop
二、关闭SELinux
vim /etc/selinux/config # 改为 SELINUX=disabled
# 保存退出,重启服务器
init 6
禁用SeLinux
#永久禁用,需要重启生效。
sed -i ’s/SELINUX=enforcing/SELINUX=disabled/g’ /etc/selinux/config
# 临时禁用,不需要重启
setenforce 0
4.root用户不能登录
# mysql -uroot -p
Enter password:
ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: NO)
# mysql -uroot -p
Enter password:
ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: YES)
设置--skip-grant-tables跳过授权表认证
service mysqld stop
在配置文件中添加--skip-grant-tables(/etc/my.cnf)
service mysqld start
另外开个SSH连接
# mysql
mysql》use mysql
mysql》update user set password=password("123456") where user="root";
mysql》flush privileges;
mysql》exit
去掉--skip-grant-tables重启mysql,root用户可以用设置的密码登录
设置root用户远程登录
GRANT ALL PRIVILEGES ON *.* TO root@’%’ IDENTIFIED BY ’123456’ WITH GRANT OPTION;
执行报如下错误,ERROR 1820 (HY000): You must SET PASSWORD before executing this statement
# mysql -uroot -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.6.27-ndb-7.4.8-cluster-gpl
Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.
Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.
Type ’help;’ or ’\h’ for help. Type ’\c’ to clear the current input statement.
mysql》
mysql》
mysql》 GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY ’root’ WITH GRANT OPTION;
ERROR 1820 (HY000): You must SET PASSWORD before executing this statement
mysql》 GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY ’root001’ WITH GRANT OPTION;
ERROR 1820 (HY000): You must SET PASSWORD before executing this statement
执行SET PASSWORD修改成功
mysql》 SET PASSWORD = PASSWORD(’root001’);
Query OK, 0 rows affected (0.02 sec)
mysql》 GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY ’root’ WITH GRANT OPTION;
Query OK, 0 rows affected (0.02 sec)
mysql》
FLUSH PRIVILEGES;
执行完成
远程连接测试,mysql集群节点,发现一个节点可以连接,一个节点不能连接
这个问题纠结很久
原因上面的操作,没有在另外一个节点上执行导致的,mysql集群的用户认证是分开管理的,要两个节点都要执行
索引以后创建用户要两个节点都执行
5.配置两个管理节点时show报错Could not get configuration
# ndb_mgm
-- NDB Cluster -- Management Client --
ndb_mgm》 show
Connected to Management Server at: 192.168.1.17:1186
ERROR Message: The cluster configuration is not yet confirmed by all defined management servers. This management server is still waiting for node 6 to connect.
Could not get configuration
* 4012: Failed to get configuration
* The cluster configuration is not yet confirmed by all defined management servers. This management server is still waiting for node 6 to connect.
ndb_mgm》 show
Cluster Configuration
---------------------
2 node(s)
id=2 (not connected, accepting connect from 192.168.1.18)
id=3 (not connected, accepting connect from 192.168.1.17)
2 node(s)
id=1 @192.168.1.17 (mysql-5.6.27 ndb-7.4.8)
id=6 @192.168.1.18 (mysql-5.6.27 ndb-7.4.8)
2 node(s)
id=4 (not connected, accepting connect from 192.168.1.17)
id=5 (not connected, accepting connect from 192.168.1.18)
两个管理节点同时都启动起来,才能看到状态
ndb_mgm》 show
Cluster Configuration
---------------------
2 node(s)
id=2 @192.168.1.18 (mysql-5.6.27 ndb-7.4.8, Nodegroup: 0, *)
id=3 @192.168.1.17 (mysql-5.6.27 ndb-7.4.8, Nodegroup: 0)
2 node(s)
id=1 @192.168.1.17 (mysql-5.6.27 ndb-7.4.8)
id=6 @192.168.1.18 (mysql-5.6.27 ndb-7.4.8)
2 node(s)
id=4 @192.168.1.17 (mysql-5.6.27 ndb-7.4.8)
id=5 @192.168.1.18 (mysql-5.6.27 ndb-7.4.8)
windows 2008 server cluster client access point is not noline 怎么处理
什么怎么了?找不到, 试试这个
Windows Server 2008磁盘清理工具
需要在Windows Server 2008上安装“桌面体验”才能使用磁盘清理工具,安装“桌面体验的”的具体步骤如下:
1. 打开“服务器管理器”——在“功能摘要”下,单击“添加功能”。
2. 在“选择功能”页上,选中“桌面体验”复选框,然后单击“下一步”。
3. 在“确认安装选项”页上,验证是否将安装桌面体验功能,然后单击“安装”。
4. 在“安装结果”页上,系统将提示您重新启动服务器以完成安装过程。单击“关闭”,然后单击“是”重新启动服务器。重新启动服务器之后,确认已安装了桌面体验。
5. 启动Server Manager,在“功能摘要”下,确认桌面体验列为已安装。
然后点击“开始”——“所有程序”——“附件”——“系统工具”——“磁盘清理”,打开磁盘清理工具

更多文章:
login failed(提示C2 NO LOGIN failed.什么意思)
2026年8月24日 02:00
js获取系统当前月份(javascript 里获取当前月份,用2位数表示,怎么整就像1月是 01. 简单的办法我现在用急啊给分)
2025年11月3日 07:15
executor shutdown不生效(我做了一个bat的文件,是设置关机时间的,但为什么不生效呢 哪位高手帮我看下)
2026年5月20日 14:30
he positioned himself at the gate的意思(值得背诵的英语美文3篇)
2025年12月10日 23:30
hadoop启动(hadoop启动namenode提示目录不存在)
2025年9月9日 12:30
subjected翻译(listen和subject的区别)
2026年1月6日 08:30
delphi aes cbc pkcs5加密(AES共有ECB,CBC,CFB,OFB,CTR五种模式分别有什么区别)
2026年4月27日 16:15
















